05-06 ZX636 owners with overheating ECU problem? - ZX6R Forum
 2Likes
  • 2 Post By 40acres
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 02-07-2016, 04:16 PM Thread Starter
Squid
 
Join Date: Sep 2014
Location: Australia
Posts: 24

I Ride: ZX636 C1
05-06 ZX636 owners with overheating ECU problem?

hi all

any local 05-06 ZX636 owners who have had the problematic overheating ECU problem?

i have read that it mainly affects 05 (can't find any on the 06) but the bike will cut out/stutter/buck after riding for around 40mins or more.
the revs would stutter/splatter as you accelerate or worse case it would cut out completely but the power and lights on dash would still be on.
I need to pull over and let it cool down for 10-20minutes before i can ride a bit further before it happens again.

seems to be affecting alot of EU & US riders, can't find many in AU/NZ.

i've checked battery and terminals, all is good
i've heat wrapped the tail part of the exhaust (yet to do the part down the leg)
relocated ECU to battery area
no diagnostic error codes come up.
all did not help, so i am led to believe that the previous owner has been riding like this for awhile and done damage to the ECU which will need replacing.

is there anything else i can try rather than replace ECU at cost of $600 with new keys...
etphonehome is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 02-07-2016, 07:05 PM
MotoGP Champion
 
40acres's Avatar
 
Join Date: Mar 2014
Location: Houston, TX
Posts: 3,202

I Ride: 2008 zx6r, 2011 kx250f
Once the ecu is damaged it remains damaged. Get on eBay and buy a used ECU that was pulled off of a 2006 model. Install ecu, hit start button, ride, smile.
Scorpi0 and etphonehome like this.
40acres is offline  
post #3 of 4 Old 02-07-2016, 08:49 PM Thread Starter
Squid
 
Join Date: Sep 2014
Location: Australia
Posts: 24

I Ride: ZX636 C1
Hi
I am in aus so i believe thr US spec ecu wont work as my bike has the k.i.s.s red ring sticker around the ignition
How ever my ecu part number indicates it doesnt have an immobilizer. I am a bit confused as i dont want to purchase an ecu from US pnly to find out it work due to the k.i.s.s system.
My ecu is the 0046.
Attached Thumbnails
Click image for larger version

Name:	ecuid.jpg
Views:	208
Size:	152.1 KB
ID:	38218  
etphonehome is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 02-07-2016, 09:07 PM
MotoGP Champion
 
40acres's Avatar
 
Join Date: Mar 2014
Location: Houston, TX
Posts: 3,202

I Ride: 2008 zx6r, 2011 kx250f
I think you've basically just answered your own question.
40acres is offline  
Reply

  ZX6R Forum > Regions > Australia


Search tags for this page

2005 kawasaki 636 zx6r ecu overheats

,

ecu overheating zx-6r

,

nz zx-6r 2016 immobilizer

Click on a term to search for related topics.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
'05 zx6r - Bike not starting and can't pinpoint the problem. Plz help! MaXiPaD Mechanical and Technical 25 09-16-2014 07:10 AM
My 05 zx636 shut off problem when riding for awhile prettyricky1 Mechanical and Technical 2 07-03-2012 06:25 AM
Engine swap, but problem with ECU? Ninja Mike Mechanical and Technical 11 06-29-2012 05:34 PM
Overheating problem solved reckless05 Mechanical and Technical 23 06-06-2012 01:32 PM
Zx636 C1H starting problem?????? zx636davo Mechanical and Technical 13 02-07-2011 12:51 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome