ZX6R.com

2009 zx6r shifting problems

This is a discussion on 2009 zx6r shifting problems within the New Users forums, part of the Lobby category; Hey everyone my names Tyler, sorry if I don't have patience to get acquainted I'm finding it hard to be calm and friendly with this ...

Go Back   ZX6R Forum > Lobby > New Users

Like Tree2Likes
Reply
 
LinkBack Thread Tools Display Modes

Old 07-16-2013, 05:48 PM   #1
Squid
 
ty ler's Avatar
 
Joined: Jul 2013
From: dsfghj

Posts: 17
Question 2009 zx6r shifting problems

Hey everyone my names Tyler, sorry if I don't have patience to get acquainted I'm finding it hard to be calm and friendly with this recent problem, I hope someone can help shed some light on my issue.
I just got a wrecked 2009 zx6r, Everything was fine except for the sub frame, shifter rod/shifter.
My friend welded the shifter it is as if new again, the pedal was broken from the foot rest.
when I get it put back on the bike it will only shift into 1st and neutral, I adjusted and tinkered around with it and got it to shift all the way up to 6th and back down again that's the last time it went above neutral.
I adjusted the shifter rod and the clutch, still nothing.
it wont shift into second, I can feel a little bump when trying switch to 2nd but wont engage (click in)..?
The previous owner said it would shift into 1st neutral and 2nd by his hands on the shifter rod after the wreck.
any ideas?
could shifter rod be bent from crash..?
ty ler is offline  
Remove Ads

Welcome to the largest Kawasaki ZX6R Forum for the Kawasaki ZX6R, ZX6RR, 636, and ZX6.

We welcome everyone and the community is free to join so register today and become part of the Kawasaki ZX6R Forum family!

Old 07-16-2013, 05:50 PM   #2
Superbike Champion
 
cwcb08's Avatar
 
Joined: Oct 2011
From: Sarnia, Ontario, CANADA

Posts: 855

I Ride: 2012 ZX600RCF - 2008 ZX600J8F - 2007 ZX600P7F
could be bent, or could need adjusting from the front, remove bold pull linkage off adjust angle try to shift, repeat
cwcb08 is offline  
Old 07-16-2013, 05:53 PM   #3
World Superbike Champion
 
d1andonlyant's Avatar
 
Joined: Apr 2011
From: Nr Cambridge, England

Posts: 2,046

I Ride: 04' ZX636
Now I may be wrong here but I think it will only shift up past neutral when the bike is moving a certain speed. Are you trying this with the bike moving?
PowerGroove and JOEY11 like this.
d1andonlyant is offline  
Old 07-16-2013, 06:39 PM   #4
Post Master General
 
givuhcky22's Avatar
 
Joined: Sep 2010
From: VA

Posts: 11,821

I Ride: 2009 GREEN ZX6R
sounds like a bent shift rod. when i wrecked. i only had 3 gears til i got the new rod. unless youre doing what was stated up there^ and you're trying to do this stationary...
givuhcky22 is offline  
Old 07-16-2013, 06:40 PM   #5
Squid
 
ty ler's Avatar
 
Joined: Jul 2013
From: dsfghj

Posts: 17
I've adjusted the shifter and where it connects to the gear, I've tried shifting while rolling the bike (in the garage, no 25mph roll).
ty ler is offline  
Old 07-16-2013, 06:42 PM   #6
Squid
 
ty ler's Avatar
 
Joined: Jul 2013
From: dsfghj

Posts: 17
engine/transmission removal needed for shift rod replacement?
ty ler is offline  
Old 07-16-2013, 06:50 PM   #7
Post Master General
 
givuhcky22's Avatar
 
Joined: Sep 2010
From: VA

Posts: 11,821

I Ride: 2009 GREEN ZX6R
Quote:
Originally Posted by ty ler View Post
I've adjusted the shifter and where it connects to the gear, I've tried shifting while rolling the bike (in the garage, no 25mph roll).
you gotta actually ride it to shift. or get the rear on a stand (kinda dangerous)

Quote:
Originally Posted by ty ler View Post
engine/transmission removal needed for shift rod replacement?
negative. remove rod, replace.
givuhcky22 is offline  
Old 07-16-2013, 06:52 PM   #8
World Superbike Champion
 
d1andonlyant's Avatar
 
Joined: Apr 2011
From: Nr Cambridge, England

Posts: 2,046

I Ride: 04' ZX636
You don't have to be moving fast to get it into second so as long as you're moving at a reasonable pace, I doubt it's that. Not trying to make you sound stupid but the bike can also only go from first to second, not neutral to second, so while you're troubleshooting don't just roll around the garage in neutral trying to upshift because that won't work
d1andonlyant is offline  
Old 07-16-2013, 06:53 PM   #9
Squid
 
ty ler's Avatar
 
Joined: Jul 2013
From: dsfghj

Posts: 17
the shift rod (rod running from peg to transmission not actual gear rod) was bent, I straightened it and is now seemingly functional
ty ler is offline  
Old 07-16-2013, 06:54 PM   #10
Post Master General
 
givuhcky22's Avatar
 
Joined: Sep 2010
From: VA

Posts: 11,821

I Ride: 2009 GREEN ZX6R
Quote:
Originally Posted by ty ler View Post
the shift rod (rod running from peg to transmission not actual gear rod) was bent, I straightened it and is now seemingly functional
soooooo then whats the problem?
givuhcky22 is offline  
Old 07-16-2013, 06:58 PM   #11
Squid
 
ty ler's Avatar
 
Joined: Jul 2013
From: dsfghj

Posts: 17
Haha! I've never heard of a bike not being able to shift from neutral to 2nd and also incapable until a certain speed, 6mph I believe if the source is correct.
Wow never knew that i'll go try again
ty ler is offline  
Old 07-16-2013, 07:00 PM   #12
World Superbike Champion
 
d1andonlyant's Avatar
 
Joined: Apr 2011
From: Nr Cambridge, England

Posts: 2,046

I Ride: 04' ZX636
Quote:
Originally Posted by givuhcky22 View Post
soooooo then whats the problem?
Haha, I'm guessing he just fixed it... although that would have been one of the first things I checked if it had been crashed and welded but you know, whatever

Enjoy the ride

Edit: no, not fixed? I'm confused
d1andonlyant is offline  
Old 07-16-2013, 07:04 PM   #13
Squid
 
ty ler's Avatar
 
Joined: Jul 2013
From: dsfghj

Posts: 17
I've also been trying it with the bike OFF due to the sub frame not being attached just rolling it up the driveway.
ty ler is offline  
Old 07-16-2013, 07:07 PM   #14
Squid
 
ty ler's Avatar
 
Joined: Jul 2013
From: dsfghj

Posts: 17
no I fixed the shift rod ( now functional but still not engaging 2nd gear)
more info, bike is off with a slow roll from neutral into second, obviously didn't work, first to second isn't working either.
Bike need to be on... ?
ty ler is offline  
Old 07-16-2013, 07:17 PM   #15
World Superbike Champion
 
d1andonlyant's Avatar
 
Joined: Apr 2011
From: Nr Cambridge, England

Posts: 2,046

I Ride: 04' ZX636
No, it should engage all gears as long as its moving at a reasonable pace i think. Push starting is a lot easier in second so that's how I used to do it on my g2 and I don't see why that wouldn't work on newer models as well. Also I can't see it really being the clutch because at real low speeds the gearbox is almost completely unloaded so it should just slip into the next gear without the clutch. I'm no mechanic and fast running out of solutions so I think I'll have to take a bit more of a back seat from here on in, but hopefully it's something stupid and not time to open her up. Good luck
d1andonlyant is offline  
Reply

  ZX6R Forum > Lobby > New Users


Search tags for this page

2009 kawasaki zx6r shifting problem

,

2009 zx6r problems

,

transmission noise when shifting on zx6r

,

zx6r bent shift rod

Click on a term to search for related topics.

Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
FS.. 2009 zx6r passenger seat.. 2009 zx6r Passenger pegs Dubguy85 Classifieds 1 07-07-2013 11:38 PM
2006/2005 vs 2009 zx6r sycotuck The ZX6R 34 11-07-2012 03:27 PM
info on the 2009 zx6r please! 2kwacks The ZX6R 4 10-23-2012 03:02 PM
parts swap for the 6r through out the years scoobs Mechanical and Technical 11 04-28-2012 05:54 PM
FS: 2009 ZX6R Race Track Street Bike Package volcom415 Classifieds 55 03-18-2012 04:29 PM