03 zx6r FI light codes 33 & 34?? - ZX6R Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 04-02-2017, 04:07 PM Thread Starter
Squid
 
Join Date: Apr 2017
Posts: 9
03 zx6r FI light codes 33 & 34??

I have a 2003 zx6r and the FI light keeps going on... It comes on when I'm in higher revs... then once it's on it stays on until I shut the bike off and turn it back on. Once turned back on the light is typically off until I get on it a little with revving it higher again. Sometimes when I try to start it the FI light blinks/ flickers and it does not start.. I managed to read the codes and the codes read a 33 and a 34... don't know what the codes mean?? Or why the light keeps coming on?? (Could it possibly be the servo motor?? Do the 2003's even have a servo motor??) NEED HELP! Thanks all!

Last edited by stssteck; 04-02-2017 at 04:10 PM.
stssteck is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 04-02-2017, 04:27 PM
Post Master General
 
Scorpi0's Avatar
 
Join Date: Feb 2012
Location: LA, Cali
Posts: 9,382

I Ride: 06 636
Code 34 is the exhaust servo. Do u have an aftermarket exhaust?

Code 33 is an O2 sensor.
Scorpi0 is online now  
post #3 of 6 Old 04-02-2017, 09:10 PM
MotoGP Champion
 
Strider's Avatar
 
Join Date: Sep 2013
Location: Texas
Posts: 3,461

I Ride: 2009 ZX-6R
Garage
Hello and welcome!

Winner - 6OTM - March 2014
2009 ZX-6R (65,695 miles and counting) | www.ZX6R.us | www.Seaton007.com

M4 GP Slip-on | ASV C5 Levers | Spiegler SS Brake Lines | SpeedoHealer V4
Custom FE | K&N Air Filter | Vortex Sprockets -1/+2 | EK MVXZ Chain
Strider is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 04-03-2017, 02:40 PM Thread Starter
Squid
 
Join Date: Apr 2017
Posts: 9
I do have an aftermarket exhaust... but I don't any wires coming out of the exhaust or cables... did they even put a servo motor on the 2003's?? The servo motor isn't under the seat where it would usually be? And I've had this exhaust on it for a couple months and it's never given me a problem.. bought the bike with the exhaust on it. also where is the 02 sensor located?
stssteck is offline  
post #5 of 6 Old 04-03-2017, 03:17 PM Thread Starter
Squid
 
Join Date: Apr 2017
Posts: 9
I just took my fairings off and there are no wires or cables coming out of my exhaust?? Where would the O2 sensor be located?
stssteck is offline  
post #6 of 6 Old 04-03-2017, 03:18 PM Thread Starter
Squid
 
Join Date: Apr 2017
Posts: 9
Quote:
Originally Posted by Scorpi0 View Post
Code 34 is the exhaust servo. Do u have an aftermarket exhaust?

Code 33 is an O2 sensor.
There are no wires of cables coming out of my exhaust?? Where would the O2 sensor be located?
stssteck is offline  
Reply

  ZX6R Forum > Lobby > New Users

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
G1-2 hugger fit j1-2 salami Mechanical and Technical 2 06-21-2016 01:36 PM
ZX6R 07 FI light lights up only when in gear! oooooooi Mechanical and Technical 9 08-17-2015 05:15 AM
2004 ZX6R B2H Ignition noise/FI light problem AdzMitch Mechanical and Technical 24 10-14-2014 11:26 AM
Kawasaki ZX6R Model Designations Lash The ZX6R 25 09-28-2014 09:26 AM
2013 ZX6r Issue(s), Electrical? Need to pull codes Litcandl3 Mechanical and Technical 8 09-09-2013 09:01 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome